×

PC Control These demos and projects allow the robot to be controlled via a computer.

ArbotiX Commander Control - These demos and projects control the Robot using the ArbotiX Commander, the handheld Arduino based remote control.

Direct Control - These demos and projects control the Robot directly from sensors connected directly to the Robot's control board.

Pose Control - These demos and projects allow you to create and playback a sequence of poses.

Serial Control - These demos and projects control the robot using a serial packet protocol.

Standalone - These demos and projects are deisgned to let your robot function without a computer or additional microcontroller.

Wireless Control - These demos and projects allow you to control the robot wirelessly - usually by replacing the Serial Connection with XBee modules.

Reference - These articles have technical details regarding the control and operation of the robot.

×

More info here

ArbotiX Getting Started Guide / Arduino IDE 1.6.X Setup

The Arbotix 1.6 Hardware/Library files are currently in public beta. Please contact us with any problems or submit a Github Issue

This guide will show you how to install the Arduino IDE (Integrated Developer Environment) on your computer and then use the Arduino IDE to program your ArbotiX-M. Completing this guide is critical to being successful with your InterbotiX kit.

The ArbotiX-M is an Arduino-Compatible micrcocontroller that is compatible with the Arduino IDE and any standard Arduino code. The ArbotiX-M has built in support for 3-Pin DYNAMIXEL servos.

This guide covers Arduino IDE version 1.6.X+. If you are looking for a guide covering the older version 1.0.6 Arduino IDE, you can find it here.

Contents:

Step 1: Setting up the Arduino Software

Click on your operating system to expand instructions to guide you through the getting started process.

ico-windows.png Click here to expand Windows Instruction

ico-apple.png Click here to expand Mac OS X Instruction

ico-linux.png Click here to expand Linux Instruction

Back to Contents

Step 2: Installing the FTDI drivers

Click on your operating system to expand instructions to guide you through the getting started process.

ico-windows.png Click here to expand Windows Instruction

ico-apple.png Click here to expand Mac OS X Instruction

ico-linux.png Click here to expand Linux Instruction

Back to Contents

Step 3: Setting up the InterbotiX Tools and Libraries

Click on your operating system to expand instructions to guide you through the getting started process.

ico-windows.png Click here to expand Windows Instruction

ico-apple.png Click here to expand Mac OS X Instruction

ico-linux.png Click here to expand Linux Instruction

Back to Contents

Step 4 : Connecting The Arbotix Robocontroller to your Computer

To program the ArbotiX-M Robocontroller from your computer you will need an Serial-to-USB device. We've tested the ArbotiX-M with a variety of FTDI USB-Serial converters, though it should also work with other adaptors(prolific, SIlabs CH30, etc). We recommend either the UartSBee or the FTDI-USB Cable.

  • In this example we will power the ArbotiX-M from the FTDI port. Move the power jumper so that it connects the middle pin and the 'USB' pin ('FTDI' for the original ArbotiX).
    arbotixm-power-select-usb-sq.png arbotix-power-select-ftdi-sq.png
    Power Jumper for ArbotiX-M Power Jumper for ArbotiX
  • The orientation of the FTDI cable is very important - it is possible to plug in the cable backwards and you will not be able to program your board. The top FTDI pin with the mark 'BLK' will always connect to the black FTDI cable. This pin is a ground or 'GND' pin. The bottom pin with the mark 'GRN' will always connect to the Green FTDI cable.Click here to learn more about powering the ArbotiX-M
  • If you are using the UartSBee, the 'BLK' and 'GRN' marking are on the underside of the board.
  • If you are using a UartSBee, make sure that the switch is set to '5v' so that the unit is running at 5v like the ArbotiX-M
  • Click here to learn about more options to program the ArbotiX-M

b_450_0_16777215_00__images_tutorials_arbotixM_arbotixm_uartsbee.png b_450_0_16777215_00__images_tutorials_arbotix_arbotix_uartsbee.png
ArbotiX-M to UartSBee Connection ArbotiX to UartSBee Connection
b_400_400_16777215_00__images_tutorials_arbotixM_arbotixm_ftdi_usb.png b_400_400_16777215_00__images_tutorials_arbotix_arbotix_ftdi_usb.png
ArbotiX-M to FTDI-USB Connection ArbotiX to FTDI-USB Connection

You cannot program the ArbotiX while an XBee is plugged into the ArbotiX or the UartSBee. You must unplug any XBees from the ArbotiX-M or UartSBee while programming. This is because the XBee and the FTDI cable are connected to the same serial port. If you wish to program the board while an XBee is plugges in, you must use ISP programming.

Back to Contents

Step 5: Program the ArbotiX-M Robocontroller to Blink

Now that your ArbotiX-M is hooked up to your computer, you will need to pick the ArbotiX board from the boards menu. Select the proper board:

Tools->Board ->ArbotiX Std
Now pick the serial port. Go to
Tools ->Serial Port
and pick the serial port for the FTDI device.
  • On Windows, the serial port will be the text COM followed by a number, like COM3
  • On Mac, the serial port will be the text /dev/cu.usbserial followed by a random number, like /dev/cu.usbserial-AL4223
  • If you have multiple serial ports and you are not sure which one is the ArbotiX-M, unplug the FTDI device from the computer, then re-open the Serial Port menu. The serial port that has disappeared is the serial port with the ArbotiX-M attached.
  • Mac and Linux users may have 2 ports - one marked 'cu.' and one marked 'tty.' Either will work.

Once you have set the board and serial port, you can open the 'ArbotixBlink' sketch.

File -> Examples -> Libraries -> ArbotiX -> arbotix -> ArbotiXBlink

Click on the 'Verify' Button (the green check in the upper left). This will attempt to compile the sketch. If all of the software is installed properly you will see a 'Done Compiling' below.
Now click on the 'Upload' button (the green arrow button next to the verify button). This will compile the sketch, and then load it onto the ArbotiX-M. If the hardware is connected properly you will see the green user light flicker while the Arduino IDE displays an 'Uploading' message. When the Arduino IDE displays 'Done Uploading' the user LED should blink on and off in a 1 second interval.
Congratulations, you just programmed your ArbotiX-M Board!

If you see any red text or error messages, then the sketch has not been loaded properly. Make sure you have installed the FTDI drivers, chosen the correct board and serial port, and that your USB connection is secure.

Back to Contents

Step 6: Program the ArbotiX-M Robocontroller to Control a DYNAMIXEL Servo

Move the power jumper towards 'VIN'. This allow you to power the ArbotiX-M from the external power supply.

arbotixm-power-select-vin-sq.png arbotix-power-select-vin-sq.png
Power Jumper for ArbotiX-M Power Jumper for ArbotiX

Next, connect your servo to the ArbotiX-M Robocontroller with a 3-pin DYNAMIXEL cable. All three DYNAMIXEL ports on the ArbotiX-M are identical, so you can plug the servo into any of them. Note: This example assumes that you are using a new AX-12A or AX-18A. All new AX servos are set to ID #1, which this example will target. This example is not intended for MX servos or servos set to IDs other than '1'.

Now you will need to connect an external power supply to the ArbotiX-M board. In this example we'll be using a 12v Switched Mode Power Supply connected to the Arbotix's power terminals through a Barrel Jack Pigtail. You can also use a charged LiPo battery connected via a LiPo battery wiring harness.

b_400_400_16777215_00__images_tutorials_arbotixM_arbotixm_single_servo.png b_400_400_16777215_00__images_tutorials_arbotix_arbotix_servo.png
Single Servo Setup for ArbotiX-M Single Servo Setup for ArbotiX

Now load the following sketch onto the ArbotiX-M Robocontroller

File -> Examples -> ArbotiX -> Test Sketchs -> AXSimpleTest

The servo should now begin to rotate counter clockwise, then clockwise. It will repeat this behavior until you power off the ArbotiX-M or re-program it.

Back to Contents

If you are working with MX servos, we reccomend you test them in the next step, Setting DYNAMIXEL IDs with the DynaManager. You can also use File -> Examples -> ArbotiX -> Test Sketchs -> MXSimpleTest , though you may need to make some adjustments to the baud rate.

Step 7: Setting Your Preferences

Arduino has many features and preferences to customize your experience. Before you get started, let's set a couple of the basic preference . Open up your preferences menu:

File -> Preferences

Mac users will find their preferences under Arduino -> Preferences

b_400_400_16777215_00__images_tutorials_arbotixM_board-5.png

Now take a look at the settings tab:

Preferences -> Settings

There is a column of checkboxes. We recommend checking "Display line numbers" for easy debugging.

b_400_400_16777215_00__images_tutorials_arbotixM_board-6.png

There is also a default setting, "Save when verifying or uploading". We recommend that you keep this checked. This will save your sketch automatically when you click on the Verify Button or the Upload Button .

b_400_400_16777215_00__images_tutorials_arbotixM_board-7.png

Congratulations, you just programmed your ArbotiX-M! Go back to the Getting Started Guide for your kit to proceed.

Back to Contents

We are still updating learn.trossenrobotics.com to accomadate the new 1.6 hardware and library files. Some documetnation may still reference

    File -> Sketchbook -> ArbotiX Sketches
    

This folder has now moved to be included in the ArbotiX Library Exaamples

    File -> Examples -> ArbotiX
    

Next: Set DYNAMIXEL IDs