Geekduino Quick Start Guide

In this guide you will learn how to setup and program your Geekduino. Many RobotGeek Assembly guides will require you to program your Geekduino as a part of setup, so it is important that you can program your Geekduino before you start assembly.

This guide will refer to the RobotGeek Geekduino, the microcontroller that will ship with RobotGeek Robot Kits. If you are using one of our Kits with another Arduino-Compatible controller, like the Arduino Uno, Seeeduino, etc, follow the setup guide from that particular manufacturer. You can then skip steps 1 and 2 on this guide, and go straight to Setting up the RobotGeek Tools and Libraries

Step 1:Setting up the Arduino Software

Arduino IDE Download

Before you can build and use your RobotGeek Kit, you will need to be able to load programs onto your Geekduino board. These programs are called 'sketches'. To load these sketches onto your board you will need to use the Arduino Integrated Developer Environment (IDE). To install the Arduino IDE do the following:

Windows users can also download a Windows Installer. This installer will install the appropriate drivers, and users can skip Step 2

The RobotGeek Kits do not currently support the Arduino 1.5 BETA IDE.

If you have any problems with this setup, the official Arduino website has a great "Getting Started with Arduino" guide for Windows, Mac, and Linux. This guide will take you through downloading the Arduino software (The Arduino IDE), drivers for your Arduino, and uploading programs(called 'sketches') to your Geekduino.
NOTE: If you are using a Seeeduino V3 or a Geekduino, you will select "Arduino Duemilanove or Nano w/ ATmega 328" when you select your board.

Step 2: Install the FTDI drivers

FTDI Drivers
Now you will need to install FTDI drivers. These drivers will allow you to communicate with your Geekduino via the USB port. Some modern Operating Systems either have these drivers or can automatically find them. If you don't have the drivers or you are unsure, you can find the FTDI drivers here, and a guide to installing them here.
Note: Windows users can download the the drivers and install them through the windows hardware wizard, or click on the 'setup executable' link automate the process.

Step 3:Setting up the RobotGeek Tools and Libraries

RobotGeek Tools and Libraries

The RobotGeek Tools and Libraries Download offers a variety of sketches and libraries for working with RobotGeek Robot Kits. First Download the Tools and Libraries ZIP file. In this .zip file, there will be two folders

  • libraries-this folder contains libraries that will add functionality to your Arduino.
  • RobotGeek Sketches-this folder contains behavioral code for robots, as well as tools for testing.
To install these files you will move these 3 folders into your 'Arduino' user folder. This is NOT the folder where the Arduino IDE itself is located. The location of this folder will be different based on your operating system.

Windows XP

My Documents\Arduino\

Windows Vista/7

Documents\Arduino\

Mac/Linux

~/Documents/Arduino/

Where '~' represents the path to your user account.


If you're having trouble finding your 'Arduino' folder, open the Arduino IDE and open the 'Preferences' panel (File->Preferences). Here you will find a file path under 'Sketchbook location:'. This is the path to your 'Arduino' folder.

When you are done, your file path should look like this



If you already have a library folder, simply copy the contents of the RobotGeek library folder into the library folder in your 'Arduino' folder.Your folder structure should look like the one shown above, along with your pre-installed files.

Step 4:Programming Your Board

If you have not already, connect your Geekduino to your computer using a USB Micro Cable. This is also a good time to make sure the Geekduino's switches are set correctly. The VCC Switch should be set to 5v and the Reset Switch should be set to AUTO. geekduinoMount0.jpg

Now that your Geekduino is hooked up to your computer, you will need to pick the correct board from the boards menu. Select the proper board:

Tools -> Board -> Arduino Duemilanove w/ ATmega 328

Now pick the correct serial port. Go to

 Tools -> Serial Port

and pick the serial port for the Geekduino

  • If you have multiple serial ports and you are not sure which one is the Geekduino, unplug the FTDI device from the computer, and watch which one dissapears.
  • Mac and Linux users may have 2 ports - one marked 'cu.' and one marked 'tty.' Either will work.

Once you have the board and serial port set, you can open the 'Blink' Sketch

File -> Examples -> 01.Basics ->Blink 
Click on the 'Verify' Button (the green check in the upper left). This will attempt to compile the sketch. If all of the software is installed properly you will see a 'Done Compiling' below the editor.

Now click on the 'Upload' button (the green arrow button next to the verify button). This will compile the sketch, and then load it onto the Geekduino. If the hardware is connected properly you will see the red TX/RX LEDs flicker while the Arduino IDE displays an 'Uploading' message. When the Arduino IDE displays 'Done Uploading' the green user LED should blink on and off in a 1 second interval. Congratulations, you just programmed your Geekduino!